duplicity 0.4.6 released

ACHTUNG: Die in diesem Artikel besprochenen Versionen sowohl von ftplicity als auch duplicity sind bereits veraltet. Die grundsätzlichen Erklärungen sind zwar weiterhin valid, aber die Syntax oder Konfigurationsparameter könnten sich geändert haben. Bitte verwendet den Such-Tag “duplicity” bzw. den Such-Tag “ftplicity” und die Kommentare, um aktuelle Informationen zu finden.

So, die neue Version 0.4.6 von duplicity wurde vom Team released (endlich mal kein RC) und auch umgehend von mir installiert und getestet.

Die Installation ist denkbar einfach:

  • Bitte vorher ein eventuell installiertes Distributions-Paket deinstallieren, damit es keine Konflikte mit der Paketverwaltung gibt. Eigenhändig installierte Vorversionen müssen aber nicht entfernt werden.
  • Download der Files:

    cd downloads # Beispielpfad
    wget http://savannah.nongnu.org/download/duplicity/duplicity-0.4.6.tar.gz

    Entpacken

    tar -xzf duplicity-0.4.6.tar.gz

  • In das Verzeichnis wechseln.

    cd duplicity-0.4.6

  • Version bauen und installieren

    python setup.py build
    python setup.py install

  • Fertig.

Für die Verwender von ftplicity: Wie alle duplicity-Versionen ab 0.4.4 funktioniert nur dies mit meiner angepassten Version von ftplicity.

LINK: Zum [duplicity]-changelog…

17 Gedanken zu „duplicity 0.4.6 released“

  1. hi,

    ich habe seit ca 1 Jahren Probleme mit dieser duplicity/ftplicity methode gekriegt, im Sinne von, es kamen kryptische Fehlermeldungen beim inkrementellen backup, die VOLL Backups liefgen immer perfekt :-(

    habs eigentlich aufgegeben, da ich in keinem Forum eine lösung gefudnen habe.

    wollte jetzt nach dem Lesen deines Artikels die Sache nochmalausprobieren, kriege aber schon bei “python setup.py build” folgende Fehler:

    _librsyncmodule.c:469: error: ‘_librsync_DeltaMakerType’ undeclared (first use in this function)
    _librsyncmodule.c:470: warning: implicit declaration of function ‘Py_InitModule’
    _librsyncmodule.c:470: error: ‘_librsyncMethods’ undeclared (first use in this function)
    _librsyncmodule.c:471: warning: implicit declaration of function ‘PyModule_GetDict’
    _librsyncmodule.c:472: error: ‘librsyncError’ undeclared (first use in this function)
    _librsyncmodule.c:472: warning: implicit declaration of function ‘PyErr_NewException’
    _librsyncmodule.c:472: error: ‘NULL’ undeclared (first use in this function)
    _librsyncmodule.c:475: warning: implicit declaration of function ‘Py_BuildValue’
    error: command ‘gcc’ failed with exit status 1

    und das ist bloss das ende der Ausgabe auf dem screen.

    kannst du mri eventuell ein Paar Tipps geben was diese Fehlermeldungen sagen wollen?

    p.s. anscheinend ist schon Version 0.4.9 erschienen.

  2. hi,

    ich habe seit ca 1 Jahren Probleme mit dieser duplicity/ftplicity methode gekriegt, im Sinne von, es kamen kryptische Fehlermeldungen beim inkrementellen backup, die VOLL Backups liefgen immer perfekt :-(

    habs eigentlich aufgegeben, da ich in keinem Forum eine lösung gefudnen habe.

    wollte jetzt nach dem Lesen deines Artikels die Sache nochmalausprobieren, kriege aber schon bei “python setup.py build” folgende Fehler:

    _librsyncmodule.c:469: error: ‘_librsync_DeltaMakerType’ undeclared (first use in this function)
    _librsyncmodule.c:470: warning: implicit declaration of function ‘Py_InitModule’
    _librsyncmodule.c:470: error: ‘_librsyncMethods’ undeclared (first use in this function)
    _librsyncmodule.c:471: warning: implicit declaration of function ‘PyModule_GetDict’
    _librsyncmodule.c:472: error: ‘librsyncError’ undeclared (first use in this function)
    _librsyncmodule.c:472: warning: implicit declaration of function ‘PyErr_NewException’
    _librsyncmodule.c:472: error: ‘NULL’ undeclared (first use in this function)
    _librsyncmodule.c:475: warning: implicit declaration of function ‘Py_BuildValue’
    error: command ‘gcc’ failed with exit status 1

    und das ist bloss das ende der Ausgabe auf dem screen.

    kannst du mri eventuell ein Paar Tipps geben was diese Fehlermeldungen sagen wollen?

    p.s. anscheinend ist schon Version 0.4.9 erschienen.

  3. Ich bin echt kein Python-Experte aber es scheint mir so, als ob Deiner Python-Installation etwas fehlt.

    Welches OS und welche Python-Version ist bei Dir am laufen?

  4. Ich bin echt kein Python-Experte aber es scheint mir so, als ob Deiner Python-Installation etwas fehlt.

    Welches OS und welche Python-Version ist bei Dir am laufen?

  5. Ich habe die gleiche Konfiguration und bei mir geht es ohne Probleme.

    Bitte überprüfe mal die Requirements auf der duplicity-Homepage (Startseite ganz unten). Mir scheint, als ob Deine librsync nicht richtig installiert ist oder Fehler hat.

    Keep me posted.

  6. Ich habe die gleiche Konfiguration und bei mir geht es ohne Probleme.

    Bitte überprüfe mal die Requirements auf der duplicity-Homepage (Startseite ganz unten). Mir scheint, als ob Deine librsync nicht richtig installiert ist oder Fehler hat.

    Keep me posted.

  7. tatsache :-) mir fehlten die pathon-dev pakete.

    vielen dank

    wäre echt toll wenn mein backup wieder gehen würde. habs damals als es in der Ct erschienen ist gleich genutzt, halt nur 1 jahr lang, danach gings einfach nicht mehr, mal sehen ob ich mit dieser neuen version mehr glück habe.

  8. tatsache :-) mir fehlten die pathon-dev pakete.

    vielen dank

    wäre echt toll wenn mein backup wieder gehen würde. habs damals als es in der Ct erschienen ist gleich genutzt, halt nur 1 jahr lang, danach gings einfach nicht mehr, mal sehen ob ich mit dieser neuen version mehr glück habe.

  9. sorry, sollte python-dev heissen in meinem letzten kommentar.
    wie gehe ic hweiter vor? ich hatte wie gesagt, alles laut CT Anleitung installiert. kann ich eifnach deinen mod von ftplicity über meine VErsion kopieren und fertig?

    du kennst ja sicher auch die ct anleitung, und deinen mod am besten, daher diese doofen fragen.

  10. sorry, sollte python-dev heissen in meinem letzten kommentar.
    wie gehe ic hweiter vor? ich hatte wie gesagt, alles laut CT Anleitung installiert. kann ich eifnach deinen mod von ftplicity über meine VErsion kopieren und fertig?

    du kennst ja sicher auch die ct anleitung, und deinen mod am besten, daher diese doofen fragen.

Schreib einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *